Groovy

Categories Technical

http://sdkman.io



root@bogon:/# curl -s get.sdkman.io | bash

Thanks for using...

SSSSSSSSSSSSSSS DDDDDDDDDDDDD KKKKKKKKK KKKKKKK
SS:::::::::::::::SD::::::::::::DDD K:::::::K K:::::K
S:::::SSSSSS::::::SD:::::::::::::::DD K:::::::K K:::::K
S:::::S SSSSSSSDDD:::::DDDDD:::::D K:::::::K K::::::K
S:::::S D:::::D D:::::DKK::::::K K:::::KKK
S:::::S D:::::D D:::::D K:::::K K:::::K
S::::SSSS D:::::D D:::::D K::::::K:::::K
SS::::::SSSSS D:::::D D:::::D K:::::::::::K
SSS::::::::SS D:::::D D:::::D K:::::::::::K
SSSSSS::::S D:::::D D:::::D K::::::K:::::K
S:::::S D:::::D D:::::D K:::::K K:::::K
S:::::S D:::::D D:::::DKK::::::K K:::::KKK
SSSSSSS S:::::SDDD:::::DDDDD:::::D K:::::::K K::::::K
S::::::SSSSSS:::::SD:::::::::::::::DD K:::::::K K:::::K
S:::::::::::::::SS D::::::::::::DDD K:::::::K K:::::K
SSSSSSSSSSSSSSS DDDDDDDDDDDDD KKKKKKKKK KKKKKKK

mmmmmmm mmmmmmm aaaaaaaaaaaaa nnnn nnnnnnnn
mm:::::::m m:::::::mm a::::::::::::a n:::nn::::::::nn
m::::::::::mm::::::::::m aaaaaaaaa:::::an::::::::::::::nn
m::::::::::::::::::::::m a::::ann:::::::::::::::n
m:::::mmm::::::mmm:::::m aaaaaaa:::::a n:::::nnnn:::::n
m::::m m::::m m::::m aa::::::::::::a n::::n n::::n
m::::m m::::m m::::m a::::aaaa::::::a n::::n n::::n
m::::m m::::m m::::ma::::a a:::::a n::::n n::::n
m::::m m::::m m::::ma::::a a:::::a n::::n n::::n
m::::m m::::m m::::ma:::::aaaa::::::a n::::n n::::n
m::::m m::::m m::::m a::::::::::aa:::a n::::n n::::n
mmmmmm mmmmmm mmmmmm aaaaaaaaaa aaaa nnnnnn nnnnnn

Now attempting installation...

Looking for a previous installation of SDKMAN...
SDKMAN found.

======================================================================================================
You already have SDKMAN installed.
SDKMAN was found at:

/root/.sdkman

Please consider running the following if you need to upgrade.

$ sdk selfupdate force

======================================================================================================

root@bogon:/# source "$HOME/.sdkman/bin/sdkman-init.sh"
root@bogon:/# sdk install groovy
==== INTERNET NOT REACHABLE! ===============================

Some functionality is disabled or only partially available.
If this persists, please enable the offline mode:

$ sdk offline

============================================================

This command is not available while offline.
root@bogon:/# sdk version
==== BROADCAST =================================================================
* 07/03/16: Gradle 2.12-rc-1 released on SDKMAN! #gradle
* 03/03/16: Grails 3.1.3 released on SDKMAN! #grailsfw
* 03/03/16: Grails 2.5.4 released on SDKMAN! #grailsfw
================================================================================
SDKMAN 3.3.2
root@bogon:/# curl -s api.sdkman.io/candidates/groovy
1.5.0,1.5.1,1.5.2,1.5.3,1.5.4,1.5.5,1.5.6,1.5.7,1.5.8,1.6.0,1.6.1,1.6.2,1.6.3,1.6.4,1.6.5,1.6.6,1.6.7,1.6.8,1.6.9,1.7.0,1.7.1,1.7.10,1.7.11,1.7.2,1.7.3,1.7.4,1.7.5,1.7.6,1.7.7,1.7.8,1.7.9,1.8.0,1.8.1,1.8.2,1.8.3,1.8.4,1.8.5,1.8.6,1.8.7,1.8.8,1.8.9,2.0.0,2.0.1,2.0.2,2.0.3,2.0.4,2.0.5,2.0.6,2.0.7,2.0.8,2.1.0,2.1.1,2.1.2,2.1.3,2.1.4,2.1.5,2.1.6,2.1.7,2.1.8,2.1.9,2.2.0,2.2.1,2.2.2,2.3.0,2.3.1,2.3.10,2.3.11,2.3.2,2.3.3,2.3.4,2.3.5,2.3.6,2.3.7,2.3.8,2.3.9,2.4.0,2.4.1,2.4.2,2.4.3,2.4.4,2.4.5,2.4.6root@bogon:/#
root@bogon:/#
root@bogon:/# sdk selfupdate force

Updating SDKMAN...

Successfully upgraded SDKMAN.

Please open a new terminal, or run the following in the existing one:

export SDKMAN_DIR="/root/.sdkman" && source "/root/.sdkman/bin/sdkman-init.sh"

root@bogon:/# export SDKMAN_DIR="/root/.sdkman" && source "/root/.sdkman/bin/sdkman-init.sh"
root@bogon:/# sdk offline enable
Offline mode enabled.
root@bogon:/# sdk offline disable
Online mode re-enabled!
root@bogon:/#
root@bogon:/# sdk install groovy

Downloading: groovy 2.4.6

% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- 0:00:01 --:--:-- 0
0 0 0 0 0 0 0 0 --:--:-- 0:00:02 --:--:-- 0
100 34.7M 100 34.7M 0 0 172k 0 0:03:26 0:03:26 --:--:-- 178k

Installing: groovy 2.4.6
Done installing!

Do you want groovy 2.4.6 to be set as default? (Y/n): Y

Setting groovy 2.4.6 as default.
root@bogon:/# groovy -v
Groovy Version: 2.4.6 JVM: 1.7.0_91 Vendor: Oracle Corporation OS: Linux
root@bogon:/#